Contact us

RESOURCES > Wordpress: There Is A New Plugin In Town

Wordpress: There Is A New Plugin In Town

Cybersecurity is vital for anyone with a website. Software which can protect your WordPress site from compromised passwords is a dream… we are here to tell you your dreams are now a reality with iThemes Security plugin.

One of the easiest ways for attackers to hack into a website is to use compromised passwords, they require little effort and can mean access within minutes. You have put a tremendous amount of time, energy and money into your website- why let a dodgy password jeopardise that?



With this in mind, iThemes Security has updated their capabilities to include a setting which refuses compromised passwords, therefore, can force users on your WordPress hosted site to use a password which does not appear in any known password breaches. This is done through tracking by Have I Been Pwned API. Data breaches are usually a list of usernames, passwords and other personal data that were exposed after a site was compromised, therefore it is essential you have a software which can refuse known breaches to prevent the hackers from succeeding.

How does iThemes Security prevent this? If a password is found in a data breach, they will require you to update your account’s password straight away. However, if you require to update the password it does NOT mean the website is compromised, only the password- prevention is key in the world of cybersecurity!

Check out iThemes Security’s helpful blog for a step-by-step guide on how to install the plug in!

If you would like to know more about WordPress and plugins, please do not hesitate to contact us- Give us a call on 01702 410663 or email us at info@07heavendesign.co.uk today!

New call-to-action

How to become a website developer - Maintenance 101